Feb
1
2012

Extensions are compatible with Joomla!2.5

Print
0 votes
Blog - Joomla! CMS
Written by:Joomler! 13637 hits

Compatible with Joomla!2.5

We will release more extensions from Joomla!2.5.

フレームワークとしての完成度と言えようか、Joomla!2.5は、よりコーディング量が減る。1.5から当たり前のように書いてきたfunctionが、コードが、ほとんど書かなくて良いようになっている。もちろん、ルールに従うことが重要だが、ルールさえ守って作成していけば、コーディング量は半分以下になると思う。

で、大きく1.5と異なる点を考えると、結論は、そう大差ないと思う。元のライブラリ側でやってくれることが増えて楽になっているのがJoomla2.5だ。と言えばわかりやすいかもしれない。同じように1.5で書いてある物なら、またコーディング量を気にしない、いや必要なコーディングだと言うならその通りだと思う。

ですが、1.6から公開されているエクステンションも徐々にJoomlaのMVCとルールに則ったエクステンションが増えたように思う。これはとても良いことでオープンソースの価値が格段にあがったと考えています。

ところが、逆にサードパーティのテンプレートは、独自のフレームワークのようなものを実装したわけのわからない物が増えているように思います。確かに独自の解釈というものは必要だと思うが、それならJoomlaの中で別のエクステンションとして実装した上でテンプレートを展開して欲しい気がする。テンプレートを開いてみるとその中にフレームワーク様な展開がされている物を見ると、とても残念な気がしてならない。(中にはデータベースのクエリ実行までWrapしているようなものもあって、とても理解できない。)

Joomla!1.6からは、パッケージとして簡単に別種のエクステンションを管理・インストールできるようになったのだから、これを利用しない手はない。

せっかく優れていると言えるJoomlaフレームワークがあるのだから、それを十分に活用した形でエクステンションを作っていきたいと常に思っています。

Tags1.5,Custom,展開,コーディング,Joomla,テンプレート,1.6,Template,Switcher,必要,エクステンション,実装,SyntaxHighlighter,Head,Compatible,Editor,Tag,2.5,Selector,フレーム,MVC
 

JContentPlus for Joomla!1.5 powered by Joomler!.net